[kaffe] patch for GZIPOutputStream
Dalibor Topic
robilad at kaffe.org
Fri May 21 12:55:24 PDT 2004
Hi Jrandom,
jrandom wrote:
> To make up for the poor variable naming in my last post
> (s/mediaType/parameter/g), here's a minipatch for GZIPOutputStream:
>
> Index: GZIPOutputStream.java
> ===================================================================
> RCS file:
> /cvs/kaffe/kaffe/libraries/javalib/java/util/zip/GZIPOutputStream.java,v
> retrieving revision 1.6
> diff -u -r1.6 GZIPOutputStream.java
> --- GZIPOutputStream.java 21 Apr 2004 14:59:06 -0000 1.6
> +++ GZIPOutputStream.java 5 May 2004 22:47:09 -0000
> @@ -108,6 +108,7 @@
>
> out.write(gzipHeader);
> // System.err.println("wrote GZIP header (" + gzipHeader.length +
> " bytes )");
> + crc = new CRC32();
> }
>
> public synchronized void write(byte[] buf, int off, int len)
>
> (crc was otherwise never initialized, causing NPE on .write)
Thanks for your patch, the issue has been fixed in GNU Classpath, and
I've merged that code over.
cheers,
dalibor topic
More information about the kaffe
mailing list